ActiveCollab Upgrade

When you run upgrade from System Settings, it can get stuck on Checking Environment step. This means that your environment does not meet system requirements of the new release.

ActiveCollab versions prior to v5.13.133 have a bug that stops displaying appropriate error messages in the interface. Instead, they are displayed only in browser's console.

To see which requirements are not met, open browser console first (here's how). Make sure that you have Console tab focused.

Next step is to go to System Settings and run the installer again. When system reaches Checking Environment step and freezes, please see what information is presented in browser console. That info should help you figure out which requrements are not met.

Once you upgrade the platform to meet the requirements of the new release, you will be able to run upgrade tool again, and complete the upgrade process.

Running Probe Script

You can run probe.php script for the quick compatibility test. Note that probe.php does not guarantee that upgrade will follow through, because ActiveCollab's upgrade system always does a more thorough analysis of the environment.